Login Issues for USM Central Customers
Incident Report for USM Central
Resolved
This issue is now resolved. If you experience an issue related to this, please contact our support team.
Posted Jun 03, 2021 - 07:02 CDT
Investigating
We are currently investigating an issue affecting login for USMC customers in some regions.
We will provide more information as it becomes available.
Posted Jun 03, 2021 - 01:54 CDT
This incident affected: USM Central Service.