Issue for USM Anywhere and USM Central in Dubai Region

Incident Report for USM Central

Update

Services continue to be impacted by incidents in 2 of the 3 availability zones for customers in the Dubai region. We do not have a timeline of when this will be resolved by AWS. It is highly recommended that customers redeploy in other European or Asia Pacific regions at this time.
Posted Mar 06, 2026 - 09:59 UTC

Identified

We are aware of an issue impacting customers deployed in the Dubai region. A power issue affecting one of the datacenters used by our cloud provider in the region is impacting our services.
Posted Mar 01, 2026 - 16:03 UTC
This incident affects: USM Central Service.