Authentication Issue

Incident Report for USM Central

Resolved

This incident has been resolved.
Posted Jan 10, 2026 - 08:55 UTC

Investigating

We are currently investigating an ongoing issue with users unable to login to their Central Platform.
Posted Jan 10, 2026 - 02:10 UTC
This incident affected: USM Central Service.