Service interruption in the Frankfurt Region
Incident Report for USM Central
Resolved
This incident has been resolved.
Posted Jun 11, 2021 - 01:04 CDT
Investigating
We are experiencing intermittent connectivity issues in the Frankfurt region to a subset of instances.
Posted Jun 10, 2021 - 16:31 CDT
This incident affected: USM Central Service.